0

Sms sent replace "@" sign with an inverted exclamation mark

Hello,

2 questions here:

When testing to send an sms in a dev application, whenever that message contains the @ sign, it is replace by an inverted exclamation mark: "¡"

So for example an sms that contains an email addres test@test.com would show on my phone as test¡test.com

I've also noticed by looking at the logs, that a message of a 150 characters long that also contains an "@" sign, that should have a MessageCount of 2 according to https://support.tropo.com/hc/en-us/articles/206241193-SMS-character-count , but it's sent only in one MessageCount. Maybe this is related to the behaviour describe above?

For example, this is what I see on the logs:

"MessageBody":"ldfjbhlkdjshfldjsbvflaisudhfldjshflajudhfladjshflasudhflkjasdhfliausdhflkjasdhfldhfskajsdhfloiausdhflajsdhfoliausdhflajsdhflaiusdhfladjshfliausdh@",
"MessageLength":146,
"MessageCount":1

But when exceeding the 160 character mark, MessageCount shows as 2

 

Is this expected behaviour, or am I missing something?

Is there any setting I should enable, or function I ought call to have the @ sign sent as is?

 

Thank you for your time. Kind regards 

1 comment

Please sign in to leave a comment.